Adobe Acrobat Reader encore troué

Sécurité

Deux vulnérabilités touchent à nouveau le célèbre lecteur sous Linux et Unix

Trois alertes de sécurité en un mois! Ca commence à faire beaucoup. Adobe Acrobat Reader multiplie les vulnérabilités, heureusement corrigées. Cette fois, deux nouvelles failles ont été identifiées dans le célèbre logiciel de lecture de documents PDF.

La première, découverte par iDEFENSE Labs, présente un risque “hautement critique”. Selon le site de veille FrSIRT, le problème résulte d’une erreur de type buffer overflow présente dans la fonction “UnixAppOpenFilePerform()” qui ne manipule pas correctement certains documents contenant un tag “/Filespec” spécialement conçu. Elle pourrait être exploitée afin d’exécuter des commandes arbitraires via un fichier PDF malicieux. La seconde faille révélée par Carsten Eiram présente un risque “bas” et résulte selon FrSIRT, d’une erreur présente au niveau des fichiers temporaires qui sont créés dans le répertoire “/tmp” de manière insécurisée, ce qui pourrait être exploité par un utilisateur malicieux afin d’accéder en lecture aux documents PDF d’un autre utilisateur. Adobe Reader version 5.0.9 et 5.0.10 sous Linux, Solaris, HP-UX, IBM-AIX sont concernés. La solution consiste à migrer vers la version 7.0 pour Linux et Solaris et la version 5.0.11 pour IBM AIX ou HP-UX.


Lire la biographie de l´auteur  Masquer la biographie de l´auteur