Failles chez les spécialistes de la… sécurité, F-Secure aussi

Sécurité

Plusieurs produits anti-virus de F-Secure présentent une faille de sécurité. Après Symantec, c’est au tour d’un autre expert ès sécurité virale de reconnaître ses vulnérabilités

F-Secure a fait état d’une faille sur plusieurs de ses produits anti-virus. C’est l’éditeur lui-même qui le révèle. Ceci démontre une nouvelle fois que les experts en sécurité ne sont pas exempts de faiblesses, plus ou moins sérieuses, comme ce fut récemment le cas pour Symantec (

lire nos articles). La vulnérabilité peut être exploitée à distance afin de “crasher” le programme anti-virus. Une mauvaise manipulation sur certaines archives LHA et le module en vérifiant le contenu entraîne une saturation de la mémoire tampon (buffer overflow) et provoque des interruptions avec déni de service.

Les différentes versions incriminées

Toutes les plates-formes sur lesquelles fonctionnent les versions de cet anti-virus fragilisé assument un risque, dont l’échelle varie de moyen à critique. Les ‘patchs’ sont proposés sur le site de l’éditeur, http://www.f-secure.com/security/fsc-2004-1.shtml.

Par ‘plusieurs de ses produits anti-virus‘ il faut entendre : F-Secure Anti-Virus pour Workstation 5.42 et suivants F-Secure Anti-Virus pour Windows Servers 5.42 et suivants F-Secure Anti-Virus pour MIMEsweeper 5.42 et suivants F-Secure Anti-Virus Client Security 5.52 et suivants F-Secure Anti-Virus pour MS Exchange 6.21 et suivants F-Secure Internet Gatekeeper 6.32 et suivants F-Secure for Firewalls 6.20 et suivants F-Secure Internet Security 2004 et suivants F-Secure Anti-Virus 2004 et suivants Solutions basées sur F-Secure Personal Express 4.5x, 4.6x et 4.7x F-Secure Anti-Virus pour Linux Workstations 4.52 et suivants F-Secure Anti-Virus pour Linux Servers 4.52 et suivants F-Secure Anti-Virus pour Linux Gateways 4.52 et suivants F-Secure Anti-Virus pour Samba Servers 4.60


Lire la biographie de l´auteur  Masquer la biographie de l´auteur