Une vulnérabilité critique touche le cœur de FreeBSD

Sécurité

Un développeur a découvert une faille critique dans l’éditeur de liens de FreeBSD. Les responsables du projet ont réagi rapidement, en proposant un premier correctif.

La carrière de FreeBSD continue à être mouvementée. Retardé dans son développement, puis dans l’annonce de sa disponibilité, FreeBSD 8.0 est maintenant touché par une sévère faille de sécurité, qui permet aux utilisateurs courants d’accéder aux privilèges de l’administrateur. Notez que ce problème touche également les versions 7.0 et 7.1 de l’OS.

Nikolaos Rangos (Kingcope) a découvert cette vulnérabilité et fourni un‘exploit’permettant de la mettre en œuvre : « Les versions récentes de FreeBSD comprennent un bogue incroyablement simple, qui permet d’accéder aux privilèges du compteroot. Il se trouve dans l’éditeur de liens (rtld) et une manipulation facile permet de l’exploiter. » Notez qu’un accès au shell du système est requis pour pouvoir profiter de cette faille.

Devant l’urgence de ce problème, Colin Percival, security officer pour le projet FreeBSD, a fourni un correctif préliminaire : « En raison du délai imposé, il est possible que cepatchne soit pas la version finale qui sera mise en ligne lorsque l’alerte sera envoyée. Il est même possible (bien que très douteux) que ce correctif ne résolve pas complètement le problème ou en introduise d’autres. Bref, utilisez-le à vos risques et périls. »

Fort heureusement, la version définitive du patch pourrait faire son apparition aujourd’hui même.


Lire la biographie de l´auteur  Masquer la biographie de l´auteur