<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="fr-FR" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="fr-FR" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="fr-FR" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
        <meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
        <meta name="news_keywords" content="serverless, cloud, développeurs, projets">
    	<title>Le serverless : une mine d&#039;or pour les développeurs - Silicon    </title>
	<link rel="profile" href="//gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.silicon.fr/wp/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://www.silicon.fr/wp-content/themes/kamino/js/html5.js"></script>
    <![endif]-->
	
<!-- This site is optimized with the Yoast SEO plugin v7.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Apparue il y a peu avec « Lambda » d&#039;Amazon Web Services et signifiant littéralement « sans serveurs », l&#039;architecture serverless s&#039;est depuis largement répandue chez tous les grands Cloud Providers."/>
<meta name="robots" content="index,follow"/>
<link rel="canonical" href="https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs" />
<link rel="publisher" href="https://plus.google.com/102940249816527808469"/>
<meta property="og:locale" content="fr_FR" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Le serverless : une mine d&#039;or pour les développeurs - Silicon" />
<meta property="og:description" content="Apparue il y a peu avec « Lambda » d&#039;Amazon Web Services et signifiant littéralement « sans serveurs », l&#039;architecture serverless s&#039;est depuis largement répandue chez tous les grands Cloud Providers." />
<meta property="og:url" content="https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs" />
<meta property="og:site_name" content="Silicon" />
<meta property="article:publisher" content="https://www.facebook.com/Siliconfr" />
<meta property="article:tag" content="serverless" />
<meta property="article:section" content="Développeurs" />
<meta property="og:image" content="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog.jpg" />
<meta property="og:image:secure_url" content="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog.jpg" />
<meta property="og:image:width" content="866" />
<meta property="og:image:height" content="653" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Apparue il y a peu avec « Lambda » d&#039;Amazon Web Services et signifiant littéralement « sans serveurs », l&#039;architecture serverless s&#039;est depuis largement répandue chez tous les grands Cloud Providers." />
<meta name="twitter:title" content="Le serverless : une mine d&#039;or pour les développeurs - Silicon" />
<meta name="twitter:site" content="@frsilicon" />
<meta name="twitter:image" content="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog.jpg" />
<meta name="twitter:creator" content="@frsilicon" />
<!-- / Yoast SEO plugin. -->

<link rel="amphtml" href="https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs/amp" /><meta name="generator" content="AMP for WP 0.9.98.22"/><link rel='dns-prefetch' href='//www.silicon.fr' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Silicon &raquo; Flux" href="https://www.silicon.fr/feed" />
<link rel="alternate" type="application/rss+xml" title="Silicon &raquo; Flux des commentaires" href="https://www.silicon.fr/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Silicon &raquo; Le serverless : une mine d&rsquo;or pour les développeurs Flux des commentaires" href="https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.silicon.fr\/wp\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.13"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="stylesheet"  href="https://www.silicon.fr/wp-content/themes/kamino/assets/refonte_v2/css/silicon-style.css?ver=1585318545" type="text/css" async="async">
<link rel='stylesheet' id='kamino-what-is-my-ip-css'  href='https://www.silicon.fr/wp-content/plugins/kamino-what-is-my-ip/css/kamino-what-is-my-ip.css?ver=1.0.0a' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.silicon.fr/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='hutt-css'  href='https://www.silicon.fr/wp-content/plugins/kamino-hutt/assets/css/hutt.css?ver=1585318545' type='text/css' media='all' />
<link rel="stylesheet"  href="https://www.silicon.fr/wp-content/plugins/kamino-post-type-expert/assets/refonte_v2/css/expert-silicon.css?ver=1585318545" type="text/css" async="async">
<link rel='stylesheet' id='pdfprnt_frontend-css'  href='https://www.silicon.fr/wp-content/plugins/kamino-print-pdf/css/frontend.css?ver=1.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='kamino_plugin_quick_registration-css'  href='https://www.silicon.fr/wp-content/plugins/kamino-quick-registration/public/css/kamino-plugin-quick-registration-public.css?ver=1.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='kamino-wonderpush-css'  href='https://www.silicon.fr/wp-content/plugins/kamino-wonderpush/public/css/kamino-wonderpush-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel="stylesheet"  href="https://www.silicon.fr/wp-content/plugins/wp-email/email-css.css?ver=2.67.6" type="text/css" async="async">
<link rel="stylesheet"  href="https://www.silicon.fr/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.4" type="text/css" async="async">
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.silicon.fr/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel="stylesheet"  href="https://www.silicon.fr/wp-content/themes/kamino/assets/css/bootstrap.min.css?ver=1_1.54.9-zABW_0.0.2-nypd" type="text/css" async="async">
<link rel="stylesheet"  href="https://www.silicon.fr/wp-content/themes/kamino/assets/css/genericons.min.css?ver=1_1.54.9-zABW_0.0.2-nypd" type="text/css" async="async">
<script type='text/javascript' src='https://www.silicon.fr/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.silicon.fr/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type="text/javascript" src="https://www.silicon.fr/wp-content/plugins/kamino-what-is-my-ip/js/jquery.flightboard.js?ver=4.9.13" defer="defer" ></script>
<script type="text/javascript" src="https://www.silicon.fr/wp-content/plugins/kamino-what-is-my-ip/js/kamino.what-is-my-ip.js?ver=4.9.13" defer="defer" ></script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/plugins/kamino-hutt/assets/js/visible.min.js?ver=4.9.13'></script>
<script type="text/javascript" src="https://www.silicon.fr/wp-content/plugins/kamino-post-type-expert/assets/js/expert.min.js?ver=1585318545" async="async" ></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pw_script_vars = {"failure_field":"Le champs email est vide","failure_form":"L'adresse email n'est pas valide","request_fail_msg":"D\u00e9sol\u00e9, votre demande a \u00e9chou\u00e9","KAMINO_SUBSCRIPTION_URL":"\/\/inscription.silicon.fr","url_post":"\/\/inscription.silicon.fr\/profile\/register-to-newsletter.php","site_name":"silicon.fr","push_data":{"site":{"name":"silicon.fr","domain":"www.silicon.fr","country":"france"},"page":"single","type":"expertadvice","id":337196,"slug":"le-serverless-une-mine-dor-pour-les-developpeurs","url":"https:\/\/www.silicon.fr\/avis-expert\/le-serverless-une-mine-dor-pour-les-developpeurs","title":"Le serverless\u00a0: une mine d&rsquo;or pour les d\u00e9veloppeurs","author":"Philippe Leroy","taxonomy":[{"name":"category","slug":"actualites","data":[{"name":"Projets","slug":"projects","sub":[{"name":"D\u00e9veloppeurs","slug":"devops"}]},{"name":"Cloud","slug":"cloud"}]},{"name":"post_tag","slug":"tag","data":[{"name":"serverless","slug":"serverless"}]},{"name":"displayed_experts","slug":"experts","data":[{"name":"Aymeric Aitamer","slug":"aymeric-aitamer"}]},{"name":"displayed_advertisers","slug":"advertiser"}]}};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.silicon.fr/wp-content/plugins/kamino-quick-registration/public/js/kamino-plugin-quick-registration-public.js?ver=1.2.3" defer="defer" ></script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/plugins/kamino-wonderpush/public/js/kamino-wonderpush-public.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var kamino_cookie_data = {"KAMINO_ANABOLIC_COOKIE_NAME":"fr9","KAMINO_SUBSCRIPTION_URL":"\/\/inscription.silicon.fr","KAMINO_SITE_NAME":"silicon.fr","string_continue":"http%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs","string_continue_label":"Silicon","string_edit_your_profile":"Modifiez votre profil","string_disconnect":"Disconnect","string_login":"Connectez-vous","string_newsletter":"Newsletter","string_cookie_privacy_text":"Nous utilisons des cookies afin de personnaliser le contenu et les fonctionnalit\u00e9s de notre site. En continuant \u00e0 naviguer, vous acceptez leur utilisation. Plus de d\u00e9tails sur notre politique d'utilisation des cookies .<a href=\"http:\/\/www.silicon.fr\/conditions-generales-dutilisation\" class=\"knowmore\">En savoir plus<\/a>","string_close":"Fermer","string_agree":"Je suis d'accord","string_donotshowmsg":"Ne plus afficher ce message"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/themes/kamino/assets/js/cookie.min.js?ver=1_1.54.9-zABW_0.0.2-nypd'></script>
<script type="text/javascript" src="https://www.silicon.fr/wp-content/themes/kamino/assets/js/utils-kamino.min.js?ver=1585318545" async="async" ></script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/themes/kamino/assets/refonte_v2/js/mobile_menu.js?ver=1585318545'></script>
<link rel='https://api.w.org/' href='https://www.silicon.fr/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.silicon.fr/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.silicon.fr/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.silicon.fr/?p=337196' />
<link rel="alternate" type="application/json+oembed" href="https://www.silicon.fr/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs" />
<link rel="alternate" type="text/xml+oembed" href="https://www.silicon.fr/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs&#038;format=xml" />
<script>
                            (function(w, d, s, id, n){
                                w[n] = w[n] || {q: [],
                                    init: function(o) {w[n].initOpts = o;},
                                    ready: function(c) {w[n].q.push(c);}};
                                var js, fjs = d.getElementsByTagName(s)[0];
                                if (d.getElementById(id)) {return;}
                                js = d.createElement(s); js.id = id;
                                js.src = "https://cdn.by.wonderpush.com/sdk/1.1/wonderpush-loader.min.js";
                                fjs.parentNode.insertBefore(js, fjs);
                            }(window, document, "script", "wonderpush-jssdk-loader", "WonderPush"));
                            
                            WonderPush.init({
                                webKey: "ad77f87d323d27593794da6caaf152341f99c2e405e1c69e40e35b975166f29f",
                                optInOptions: {
                                    externalBoxMessage: "Vous recevrez de notre part des notifications personnalisées.",
                                    externalBoxExampleTitle: "Exemple de notification",
                                    externalBoxExampleMessage: "Ceci est un exemple de notification",
                                    externalBoxDisclaimer: "Vous avez la possibilité de vous désabonner à tout moment",                         
                                    modalBoxMessage: "Vous recevrez de notre part des notifications personnalisées. <br/>Vous avez la possibilité de vous désabonner à tout moment",
                                    modalBoxButton: "J'ai compris !",
                                    externalBoxProcessingMessage: "Inscription en cours",
                                    externalBoxSuccessMessage: "Merci pour votre inscription !",
                                    externalBoxFailureMessage: "Nous sommes désolés, une erreur est survenue",
                                    externalBoxTooLongHint: "Connexion faible ou navigation privée ?",
                                    externalBoxCloseHint: "Fermer"
                                }
                            });
                            </script><!-- <meta name="NextGEN" version="2.2.45" /> -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<script type="text/javascript">
		(function ($) {
			$(window).load(function() {
				AdBlocker = (function () {
					USE_ADBLOCK = null;
					function kamino_detect_adblock(){
						var detect = 0;
						if( $('.dfp_ad').find('iframe').length == 0 ){
							detect = 1;
						}

						if(detect == 1){ USE_ADBLOCK = true; }
						else{ USE_ADBLOCK = false; }

						return USE_ADBLOCK;
					}
					return kamino_detect_adblock();
				})();
			});
		}(jQuery));
	</script>
					<script>
					window.dataLayer = window.dataLayer || [];
					dataLayer.push({
						'page': {
							'publicationDate': '2020_03_30',
							'author': 'philippe_leroy',
							'tagContent': 'serverless',
							'format': 'avis_expert_article',
							'canonicalSite': undefined,
							'parentPage': undefined,
							'childPage': undefined,
							'companyId': undefined,
							'contentId': undefined,
							'templatePage': 'edito'						},
						'user': {
							'userProfile': 'anonymous'						}
					});
				</script>
							<!-- Google Tag Manager -->
			<script>
				(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-WH9J3VR');
			</script>
			<!-- End Google Tag Manager -->
			
    <!-- SMILEWANTED TAG-->
    <script type="text/javascript" src="//tags.smilewanted.com/formats/corner-video/silicon.fr"></script>

		<script type="text/javascript">
		(function ($) {
			$(window).load(function() {
				function TrackEventCookie() {
					var messageCookie = ""
					var stateCookie = navigator.cookieEnabled;
					stateCookie == true ? messageCookie = "COOKIE_OK" : messageCookie = "COOKIE_KO";
					ga('send', 'event', 'Track the use of Cookies', 'Cookies', messageCookie );
				}
				return TrackEventCookie();
			});
		}(jQuery));
		</script>
		<script type='text/javascript'>      
		var wamid = '3799'; /* Wam Account ID */
		var typ = '1'; /* Event Type default 1 */
		var Wvar = {
			"content_id":0,
			"profile":'anonymous',
			"userid":undefined,
			"job-description":undefined,
			"industrial-sector":undefined,
			"number-of-employees":undefined,
			"format":'avis_expert_article',
			"tags":'serverless',
			"category":'cloud|devops|projects',
			"device":"desktop"};		
		(function () {
			var w = document.createElement("script");
			w.type = "text/javascript";
			w.src = document.location.protocol + "//cstatic.weborama.fr/js/wam/customers/wamfactory_dpm.wildcard.min.js?rnd=" + new Date().getTime();           
			w.async = true;
			var body = document.getElementsByTagName('script')[0];
			body.parentNode.insertBefore(w, body);
		})();
	</script>
		<link rel="shortcut icon"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/favicon-16x16.png" sizes="16x16">
	<link rel="apple-icon" sizes="57x57"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-57x57.png">
	<link rel="apple-icon" sizes="114x114"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-114x114.png">
	<link rel="apple-icon" sizes="72x72"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-72x72.png">
	<link rel="apple-icon" sizes="144x144"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-144x144.png">
	<link rel="apple-icon" sizes="60x60"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-60x60.png">
	<link rel="apple-icon" sizes="120x120"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-120x120.png">
	<link rel="apple-icon" sizes="76x76"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-76x76.png">
	<link rel="apple-icon" sizes="152x152"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-152x152.png">
	<link rel="apple-icon" sizes="180x180"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/apple-icon-180x180.png">
	<link rel="icon" type="image/png"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/favicon-96x96.png" sizes="96x96">
	<link rel="icon" type="image/png"
	      href="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/favicon-32x32.png" sizes="32x32">

	<meta name="application-name" content="silicon.fr"/>
	<meta name="msapplication-TileColor" content="#7272A0"/>
	<meta name="msapplication-square70x70logo"
	      content="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/ms-icon-70x70.png"/>
	<meta name="msapplication-square150x150logo"
	      content="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/ms-icon--150x150.png"/>
	<meta name="msapplication-wide310x150logo"
	      content="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/ms-icon-310x150.png"/>
	<meta name="msapplication-square310x310logo"
	      content="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/ms-icon-310x310.png"/>

	<style>
    #wp-admin-bar-ampforwp-view-amp a{
    background:url(data:image/svg+xml;base64,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) !important;
    background-size: 18px !important;
    background-repeat: no-repeat !important;
 		background-position: 4px 7px !important;
 		text-indent: -99999px;
 		width: 12px;
}</style>		<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "NewsArticle",
			"author": {
				"@type": "Person",
				"name": "Philippe Leroy"
			},
			"name": "Le serverless : une mine d&#039;or pour les développeurs",
			"description": "Apparue il y a peu avec « Lambda » d'Amazon Web Services et signifiant littéralement « sans serveurs », l'architecture serverless s'est depuis largement répandue chez tous les grands Cloud Providers. ",
			"thumbnailUrl": "https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog.jpg",
			"datePublished": "2020-03-30T18:00:14+00:00",
			"dateModified": "2020-03-30T18:00:14+00:00",
			"articleSection": "Cloud",
			"headline": "Le serverless : une mine d&#039;or pour les développeurs",
			"image": {
				"@type": "ImageObject",
				"url": "https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog.jpg",
				"width": "866",
				"height": "653"
			},
			"publisher" : {
				"@type": "Organization",
				"name": "Silicon",
				"logo" : {
					"@type": "ImageObject",
					"url": "https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/mstile-70x70.png",
					"width": "",
					"height": ""
				}
			},
			"mainEntityOfPage": {
				"@type": "WebPage",
				"id": "https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs"
			}
		}
		</script>
                <!-- Asynchronous GPT tag -->
                <script type="text/javascript">
                    var googletag = googletag || {};
                    googletag.cmd = googletag.cmd || [];
                    (function () {
                        var gads = document.createElement("script");
                        gads.async = true;
                        gads.type = "text/javascript";
                        var useSSL = "https:" == document.location.protocol;
                        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
                        var node = document.getElementsByTagName("script")[0];
                        node.parentNode.insertBefore(gads, node);
                    })();


                </script>
                <!-- END asynchronous GPT tag -->

                <link rel="icon" href="https://www.silicon.fr/wp-content/uploads/2019/11/cropped-favicon-silicon-16x16-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.silicon.fr/wp-content/uploads/2019/11/cropped-favicon-silicon-16x16-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.silicon.fr/wp-content/uploads/2019/11/cropped-favicon-silicon-16x16-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.silicon.fr/wp-content/uploads/2019/11/cropped-favicon-silicon-16x16-270x270.png" />
	    <script type="text/javascript">
        var kamino_triggeredfrom = 'https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs';
    </script>
</head>

<body class="expertadvice-template-default single single-expertadvice postid-337196 partner-page france silicon">

<!-- Slider Editorial special -->

<div class="only-for-desktop"></div>    <script type="text/javascript">
        dfp_device_view = "mobile";
        hutt_defineSlot = {};
        hutt_defineSlot_slot_object = {};
        hutt_defineSlot_slot_object_infinite_scroll = [];
                hutt_original_page_id = "337196";
        
        //This will detect if we are on desktop or mobile device
        var only_for_desktop = jQuery(".only-for-desktop").filter(":visible");
        if(only_for_desktop.length > 0){
            dfp_device_view = "desktop";
        }

        googletag.cmd.push(function() {
googletag.pubads().enableSingleRequest();googletag.pubads().collapseEmptyDivs();googletag.pubads().disableInitialLoad();googletag.enableServices();});
        var refresh_slots = function(){

            /*for (var k in hutt_defineSlot) {
             console.log('This size is currently on hutt_defineSlot array: '+ k);
             }*/

            for (var k in hutt_defineSlot) {
                var el = document.getElementById(k);

                // We display automatically some out of page tags
                // else in exemple the skin will be displayed only if we see the bottom of the page
                if( hutt_defineSlot[k]['size'] == '[1,1]' || hutt_defineSlot[k]['size'] == '[2,2]' || hutt_defineSlot[k]['size'] == '[3,3]' || hutt_defineSlot[k]['size'] == '[4,4]' || hutt_defineSlot[k]['size'] == '[5,5]' || hutt_defineSlot[k]['size'] == '[6,6]'){
                    //console.log(k+': is now displayed (init)');
                    googletag.pubads().refresh([hutt_defineSlot_slot_object[k]['slot']], {changeCorrelator: false});
                    delete hutt_defineSlot[k];
                    continue;
                }

                if (isvisible(jQuery(el), true)) {
                    //console.log(k+': is now displayed (visible)');
                    googletag.pubads().refresh([hutt_defineSlot_slot_object[k]['slot']], {changeCorrelator: false});
                    delete hutt_defineSlot[k];
                    continue;
                }
            }
        };

        // allow us to display ads when API is ready.
        googletag.cmd.push(function () {

            refresh_slots();

            setTimeout(function(){
                refresh_slots();
            }, 200);

            setTimeout(function(){
                refresh_slots();
            }, 1500);

            setTimeout(function(){
                refresh_slots();
            }, 2500);

            var locked = false;
            var win = jQuery(window);
            win.scroll(function(event) {
                if(locked || hutt_defineSlot === null || hutt_defineSlot === undefined){
                    return;
                }
                //console.log('scroll');
                locked = true;
                for (var k in hutt_defineSlot) {
                    var el = document.getElementById(k);
                    if (isvisible(jQuery(el), true)) {
                        //console.log(k+': is now displayed (scroll)');
                        googletag.pubads().refresh([hutt_defineSlot_slot_object[k]['slot']], {changeCorrelator: false});
                        delete hutt_defineSlot[k];
                        continue;
                    }
                }
                locked = false;
            });

        });
            </script>
    <script type="text/javascript" id="DESKTOP_SKIN-337196-0">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_SKIN-337196-0");var scr = document.getElementById("DESKTOP_SKIN-337196-0");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_SKIN-337196-0");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_SKIN-0 desktop sticky-DESKTOP_SKIN-337196-0");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[1, 1], "div-gpt-ad-DESKTOP_SKIN-337196-0").setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[1, 1]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_SKIN-337196-0"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_SKIN-337196-0"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_SKIN-337196-0"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_SKIN-337196-0"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_SKIN-337196-0");});}</script>			<script>
			window.beOpinionAsyncInit = function() {
				BeOpinionSDK.init({
					account: "5ca477fb46e0fb00017d9d72",
				});
				BeOpinionSDK.watch();
			}
			</script>
			<script async src="https://widget.beopinion.com/sdk.js"></script><!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WH9J3VR" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<header role="banner">
<div id="primary-bar" class=" titlewording ">
        <div class="wrapper clearfix">
                                <div class="btn-menu-mobile"><a href="#"></a></div>
                    <ul id="menu-menu-right-v2" class="menu-mobile nav-menus"><li id="menu-item-334884" class="menu-item menu-item-type-taxonomy menu-item-object-category current-expertadvice-ancestor current-menu-parent current-expertadvice-parent menu-item-334884"><a href="https://www.silicon.fr/actualites/cloud">Cloud</a></li>
<li id="menu-item-334885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334885"><a href="/tag/blockchain">Blockchain</a></li>
<li id="menu-item-334886" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334886"><a href="https://www.silicon.fr/actualites/security">Cybersécurité</a></li>
<li id="menu-item-334887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334887"><a href="https://www.silicon.fr/actualites/mobility">Télécom/Mobilité</a></li>
<li id="menu-item-335032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335032"><a href="https://www.silicon.fr/actualites/workspace">Workplace</a></li>
<li id="menu-item-334889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334889"><a href="https://www.silicon.fr/actualites/software">Logiciels</a></li>
<li id="menu-item-334890" class="marketingLink menu-item menu-item-type-custom menu-item-object-custom menu-item-334890"><a href="https://livreblanc.silicon.fr/">Livres Blancs</a></li>
<li id="menu-item-334891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334891"><a href="/dossiers">Dossiers</a></li>
<li id="menu-item-334893" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334893"><a href="/evenement">Events</a></li>
<li id="menu-item-334894" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334894"><a href="/avis-expert">Avis d&rsquo;experts</a></li>
<li id="menu-item-334895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-334895"><a href="#">insight center</a>
<ul class="sub-menu">
	<li id="menu-item-334896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334896"><a href="/hub/ibm-cloud">HUB IBM CLOUD</a></li>
	<li id="menu-item-334897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334897"><a href="/hub/colt-hub">Hub Colt</a></li>
</ul>
</li>
</ul>		<div class="site-title  ">
								<a href="http://silicon.fr" title="Silicon" rel="home">
						<img src="https://www.silicon.fr/wp-content/themes/kamino/assets/images/logos_silicon/france.png" alt="Silicon">
					</a>
									</div>
	            <div class="top-menu">
                <ul id="menu-top" class="nav-menus"><li id="menu-item-97217" class="follow menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-97217"><a href="#">Suivez-nous</a>
<ul class="sub-menu">
	<li id="menu-item-97235" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97235"><a target="_blank" rel="nofollow" href="https://www.facebook.com/pages/Siliconfr/137530299596488">Facebook</a></li>
	<li id="menu-item-97236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97236"><a target="_blank" rel="nofollow" href="https://www.twitter.com/frsilicon">Twitter</a></li>
	<li id="menu-item-97239" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97239"><a target="_blank" rel="nofollow" href="https://itunes.apple.com/app/silicon.fr/id527985600?mt=8">IOS App</a></li>
	<li id="menu-item-97240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97240"><a target="_blank" rel="nofollow" href="https://play.google.com/store/apps/details?id=org.com.siliconfr">Android App</a></li>
	<li id="menu-item-97243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97243"><a target="_blank" rel="nofollow" href="/feed">Flux RSS</a></li>
</ul>
</li>
<li id="menu-item-97218" class="newsletter menu-item menu-item-type-custom menu-item-object-custom menu-item-97218"><a rel="nofollow" href="#">Newsletters</a></li>
<li id="menu-item-97219" class="connect menu-item menu-item-type-custom menu-item-object-custom menu-item-97219"><a rel="nofollow" href="#">Connectez-vous</a></li>
<li id="menu-item-336780" class="subscription-popin__button menu-item menu-item-type-custom menu-item-object-custom menu-item-336780"><a href="#">Je m&rsquo;abonne</a></li>
</ul>            </div>
            
	<div id="Subscription-popin" class="modal-subscription-popin">
		<div class="subscription-popin">
			<img src="https://www.silicon.fr/wp-content/uploads/2020/03/silicon-marketing-commercia-1.png" title="" alt="">
			<div class="subscription-content">
				<div class="subscription-item__over">
					<div class="subscription-item__over-icon">
						<span class="icon-edition"></span>
					</div>
					<div class="subscription-item__over-label">Edition Papier</div>
				</div>
				<!-- <div class="subscription-item__over">
					<div class="subscription-item__over-icon">
						<span class="icon-devices"></span>
					</div>
					<div class="subscription-item__over-label">Magazine numérique</div>
				</div> -->
				<div class="subscription-item__over">
					<a href="http://boutique.editialis.fr/marketing-commercial/silicon" class="subscription__over-button" target="_blank">Je m'abonne</a>
				</div>
			</div>
		</div>
	</div>

            <div class="search-button">
    <form role="search" class="searchSubmitForm search-form" method="get"
          action="https://www.silicon.fr/">
        <label>
            <span class="screen-reader-text">Search for:</span>
            <input type="search" class="search-field"
                   placeholder=""
                   value="" name="s"
                   title="Rechercher&nbsp;:"/>
            <div class="icon-search"></div>
        </label>

        <input type="submit" class="search-submit" value="Rechercher"/>
    </form>

    </div>
        </div>
    </div>

    <nav id="secondary-bar">
        <div class="wrapper clearfix">
            <ul id="menu-menu-left-v2" class="left nav-menus"><li id="menu-item-334881" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-334881"><a href="#">Menu</a>
<ul class="sub-menu">
	<li id="menu-item-334882" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-334882"><a href="/">Articles</a>
	<ul class="sub-menu">
		<li id="menu-item-334883" class="menu-item menu-item-type-taxonomy menu-item-object-category current-expertadvice-ancestor current-menu-parent current-expertadvice-parent menu-item-has-children menu-item-334883"><a href="https://www.silicon.fr/actualites/cloud">Cloud</a>
		<ul class="sub-menu">
			<li id="menu-item-334899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334899"><a href="https://www.silicon.fr/actualites/cloud/datacenter">Datacenters</a></li>
			<li id="menu-item-334900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334900"><a href="https://www.silicon.fr/actualites/cloud/iaas">IAAS</a></li>
			<li id="menu-item-334901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334901"><a href="https://www.silicon.fr/actualites/cloud/cloud-management">Orchestration</a></li>
			<li id="menu-item-334902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334902"><a href="https://www.silicon.fr/actualites/cloud/paas">PAAS</a></li>
			<li id="menu-item-334903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334903"><a href="https://www.silicon.fr/actualites/cloud/server">Serveurs</a></li>
			<li id="menu-item-334904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334904"><a href="https://www.silicon.fr/actualites/cloud/virtualization">Virtualisation</a></li>
		</ul>
</li>
		<li id="menu-item-334905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-334905"><a href="https://www.silicon.fr/actualites/data-storage">Data &#038; Stockage</a>
		<ul class="sub-menu">
			<li id="menu-item-334906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334906"><a href="https://www.silicon.fr/actualites/data-storage/database">Bases de données</a></li>
			<li id="menu-item-334907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334907"><a href="https://www.silicon.fr/actualites/data-storage/bigdata">Big Data</a></li>
			<li id="menu-item-334908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334908"><a href="https://www.silicon.fr/actualites/data-storage/business-intelligence">Business Intelligence</a></li>
			<li id="menu-item-334909" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334909"><a href="https://www.silicon.fr/actualites/data-storage/dataviz">Dataviz</a></li>
			<li id="menu-item-334910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334910"><a href="https://www.silicon.fr/actualites/data-storage/storage">Stockage</a></li>
		</ul>
</li>
		<li id="menu-item-334911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334911"><a href="/tag/iot">IoT</a></li>
		<li id="menu-item-334912" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334912"><a href="https://www.silicon.fr/actualites/software/erp-suites">ERP</a></li>
		<li id="menu-item-334913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334913"><a href="https://www.silicon.fr/actualites/software/open-source">Open Source</a></li>
		<li id="menu-item-334914" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334914"><a href="https://www.silicon.fr/actualites/projects/cio">DSI</a></li>
		<li id="menu-item-334915" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334915"><a href="https://www.silicon.fr/actualites/projects/service-provider">SSII</a></li>
		<li id="menu-item-334916" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334916"><a href="https://www.silicon.fr/actualites/e-regulation/legal">Legislation</a></li>
		<li id="menu-item-334917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334917"><a href="https://www.silicon.fr/actualites/security">Cybersécurité</a></li>
	</ul>
</li>
	<li id="menu-item-334918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334918"><a href="//livreblanc.silicon.fr/">Livres Blancs</a></li>
	<li id="menu-item-334920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334920"><a href="/evenement/">Events</a></li>
	<li id="menu-item-334921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334921"><a href="/avis-expert">avis d&rsquo;experts</a></li>
	<li id="menu-item-334930" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-334930"><a href="#">Insight center</a>
	<ul class="sub-menu">
		<li id="menu-item-334922" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334922"><a href="/hub/colt-hub">Hub Colt</a></li>
		<li id="menu-item-334923" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334923"><a href="/hub/malwarebytes-hub">Hub Cyber-sécurité</a></li>
		<li id="menu-item-334924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334924"><a href="/hub/hpe-intel-hub">Hub HPE</a></li>
		<li id="menu-item-334933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334933"><a href="#">Et si votre transformation digitale passait d’abord par un ERP Cloud ?</a></li>
		<li id="menu-item-334934" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334934"><a href="#">Les solutions innovantes de Huawei Enterprise</a></li>
	</ul>
</li>
</ul>
</li>
</ul>            <ul id="menu-menu-right-v2-1" class="right nav-menus"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-expertadvice-ancestor current-menu-parent current-expertadvice-parent menu-item-334884"><a href="https://www.silicon.fr/actualites/cloud">Cloud</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334885"><a href="/tag/blockchain">Blockchain</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334886"><a href="https://www.silicon.fr/actualites/security">Cybersécurité</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334887"><a href="https://www.silicon.fr/actualites/mobility">Télécom/Mobilité</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335032"><a href="https://www.silicon.fr/actualites/workspace">Workplace</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334889"><a href="https://www.silicon.fr/actualites/software">Logiciels</a></li>
<li class="marketingLink menu-item menu-item-type-custom menu-item-object-custom menu-item-334890"><a href="https://livreblanc.silicon.fr/">Livres Blancs</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334891"><a href="/dossiers">Dossiers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334893"><a href="/evenement">Events</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334894"><a href="/avis-expert">Avis d&rsquo;experts</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-334895"><a href="#">insight center</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334896"><a href="/hub/ibm-cloud">HUB IBM CLOUD</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334897"><a href="/hub/colt-hub">Hub Colt</a></li>
</ul>
</li>
</ul>
            <div class="mobileRightNav">
                <div class="search-button">
    <form role="search" class="searchSubmitForm search-form" method="get"
          action="https://www.silicon.fr/">
        <label>
            <span class="screen-reader-text">Search for:</span>
            <input type="search" class="search-field"
                   placeholder=""
                   value="" name="s"
                   title="Rechercher&nbsp;:"/>
            <div class="icon-search"></div>
        </label>

        <input type="submit" class="search-submit" value="Rechercher"/>
    </form>

    </div>
            </div>
        </div>
    </nav>
</header>

    <header class="single-nav single-nav-V2">
        <div class="wrapper clearfix">
            <div class="single-scroll-top"><div class="glyphicon glyphicon-chevron-up"></div></div>
            <div class="single-title">Le serverless : une mine d&rsquo;or pour les développeurs</div>
            <div class="top-menu">
                <ul id="menu-top-1" class="nav-menus"><li class="follow menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-97217"><a href="#">Suivez-nous</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97235"><a target="_blank" rel="nofollow" href="https://www.facebook.com/pages/Siliconfr/137530299596488">Facebook</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97236"><a target="_blank" rel="nofollow" href="https://www.twitter.com/frsilicon">Twitter</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97239"><a target="_blank" rel="nofollow" href="https://itunes.apple.com/app/silicon.fr/id527985600?mt=8">IOS App</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97240"><a target="_blank" rel="nofollow" href="https://play.google.com/store/apps/details?id=org.com.siliconfr">Android App</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97243"><a target="_blank" rel="nofollow" href="/feed">Flux RSS</a></li>
</ul>
</li>
<li class="newsletter menu-item menu-item-type-custom menu-item-object-custom menu-item-97218"><a rel="nofollow" href="#">Newsletters</a></li>
<li class="connect menu-item menu-item-type-custom menu-item-object-custom menu-item-97219"><a rel="nofollow" href="#">Connectez-vous</a></li>
<li class="subscription-popin__button menu-item menu-item-type-custom menu-item-object-custom menu-item-336780"><a href="#">Je m&rsquo;abonne</a></li>
</ul>            </div>
        </div>
    </header>

<div id="page" class="hfeed site">
            <div id="main" class="wrapper clearfix">
            <script type="text/javascript" id="MOBILE_BANNER-337196-1">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:MOBILE_BANNER-337196-1");var scr = document.getElementById("MOBILE_BANNER-337196-1");var device = "mobile";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-MOBILE_BANNER-337196-1");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-MOBILE_BANNER-1 mobile sticky-MOBILE_BANNER-337196-1");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[[320, 50], [300, 50], [300, 100]], "div-gpt-ad-MOBILE_BANNER-337196-1").setTargeting("pos", 1).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[[320, 50], [300, 50], [300, 100]]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-MOBILE_BANNER-337196-1"] = {};hutt_defineSlot["div-gpt-ad-MOBILE_BANNER-337196-1"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_BANNER-337196-1"] = {};hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_BANNER-337196-1"]["slot"] = slot;googletag.display("div-gpt-ad-MOBILE_BANNER-337196-1");});}</script><script type="text/javascript" id="DESKTOP_MEGA-337196-1">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_MEGA-337196-1");var scr = document.getElementById("DESKTOP_MEGA-337196-1");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_MEGA-337196-1");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_MEGA-1 desktop sticky-DESKTOP_MEGA-337196-1");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[[728, 90], [728, 200], [976, 220], [970, 90], [970, 150], [970, 250], [1014, 90], [1014, 200], [1014, 300], [1080, 90], [1080, 200], [1080, 250], [1080, 300], [1080, 440], [978, 250], [1000, 200], [1000, 300], [1000, 90], [728, 270]], "div-gpt-ad-DESKTOP_MEGA-337196-1").setTargeting("pos", 1).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[[728, 90], [728, 200], [976, 220], [970, 90], [970, 150], [970, 250], [1014, 90], [1014, 200], [1014, 300], [1080, 90], [1080, 200], [1080, 250], [1080, 300], [1080, 440], [978, 250], [1000, 200], [1000, 300], [1000, 90], [728, 270]]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_MEGA-337196-1"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_MEGA-337196-1"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_MEGA-337196-1"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_MEGA-337196-1"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_MEGA-337196-1");});}</script><div id="infinite-scroll-marker-start" style="display: none;"></div>
<div id="content" class="site-content content-337196" role="main">
	<p id="breadcrumbs"><span><span><a href="https://www.silicon.fr/" >Accueil</a> &gt; <span><a href="https://www.silicon.fr/avis-expert" >Avis d&#039;experts de l&#039;IT</a> &gt; <span class="breadcrumb_last"></span></span></span></span></p>			<article id="post-337196" class="clearfix post-337196 expertadvice type-expertadvice status-publish has-post-thumbnail hentry category-cloud category-devops category-projects tag-serverless displayed_experts-aymeric-aitamer"  itemscope itemtype="http://schema.org/NewsArticle">
			<!-- Header -->
			<header class="entry-header">
				<h1 class="entry-title" itemprop="name">Le serverless : une mine d&rsquo;or pour les développeurs</h1>
				<div class="entry-author-date">
					Aymeric Aitamer, <span class="date"><a href="https://www.silicon.fr/date/2020/03/30" rel="bookmark"><time class="entry-date" datetime="2020-03-30T18:00:14+00:00" itemprop="datePublished">30 mars 2020, 18:00</time></a></span>				</div>
				<div itemprop="breadcrumb" class="entry-breadcrumb"><a href="https://www.silicon.fr/actualites/cloud" title="View all posts in Cloud">Cloud</a><a href="https://www.silicon.fr/actualites/projects/devops" title="View all posts in Développeurs">Développeurs</a><a href="https://www.silicon.fr/actualites/projects" title="View all posts in Projets">Projets</a></div>				<div class="entry-tools"></div>
			</header>
			<!-- .entry-header -->
			<section class="wrap-article-content">
				<div class="articleWrapper">
					<div class="entry-social-v3 postID-337196" data-postid="337196">
						<!-- debug| stdClass Object
(
    [facebook] => 0
    [google] => 0
    [twitter] => 0
    [linkedin] => 0
    [meneame] => 0
    [comment] => 0
    [total] => 0
    [__cache_timestamp] => 0
    [__cache_type] => -2
)
|-->            <div class="facebook-share btnShare">
                <a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs" target="_blank" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=400,width=600');return false;">
                    <span class="socialIco">
                        <i class="fa fa-facebook" aria-hidden="true"></i> Facebook
                    </span>
                                    </a>
            </div>
                        <div class="twitter-share btnShare">
                <a rel="nofollow"
                   href="https://twitter.com/share?text=Le+serverless%C2%A0%3A+une+mine+d%27or+pour+les+d%C3%A9veloppeurs&url=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs"
                   target="_blank"
                   onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=400,width=600');return false;">
                    <span class="socialIco"> <i class="fa fa-twitter" aria-hidden="true"></i> Twitter</span>

                </a>
            </div>
                        <div class="linkedin-share btnShare">
                <a rel="nofollow" href="http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs&title=Le+serverless%C2%A0%3A+une+mine+d%27or+pour+les+d%C3%A9veloppeurs&source=https%3A%2F%2Fwww.silicon.fr" target="_blank" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=400,width=600');return false;">
                    <span class="socialIco"> <i class="fa fa-linkedin" aria-hidden="true"></i> Linkedin</span>
                                    </a>
            </div>
                            <div class="nlSubscriber btnShare">
                    <a rel="nofollow" href="//inscription.silicon.fr/profile/new-profile-1.php?&continue=http%3A%2F%2Fwww.silicon.fr&continue_label=Silicon" target="_blank">
                        <span class="socialIco"><i class="fa fa-envelope-o" aria-hidden="true"></i></span>
                    </a>
                </div>
                            <div class="comment-share btnShare" data-postid="337196">
                <a itemprop="discussionUrl" rel="nofollow" onclick="kamino_expand_comments('#comment-share-337196');" href="#comments-337196">
                    <span class="socialIco"><i class="fa fa-comment" aria-hidden="true"></i></span>
                                    </a>
            </div>
            <div class="pdfprnt-buttons pdfprnt-buttons-custom pdfprnt-buttons-expertadvice pdfprnt-top-right"><a href="https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs?print=pdf" class="pdfprnt-button pdfprnt-button-pdf" target="_blank" rel="nofollow" ><i class="fa fa-file-pdf-o"></i></a><a href="https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs?print=print" class="pdfprnt-button pdfprnt-button-print" target="_blank" rel="nofollow" ><i class="fa fa-print"></i></a></div>					</div>
					<div class="imageTitleWrapper">
												<picture class="img">
							<source srcset="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog-684x513.jpg" media="(min-width: 1080px)">
							<source srcset="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog-440x330.jpg">
							<img src="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog-684x513.jpg" srcset="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog-684x513.jpg" alt="">
						</picture>
					</div>

					<!-- .entry-header -->
					<section class="article-content"  itemprop="articleBody">
												<div class="entry-excerpt"><p>Apparue il y a peu avec « Lambda » d&rsquo;Amazon Web Services et signifiant littéralement « sans serveurs », l&rsquo;architecture serverless s&rsquo;est depuis largement répandue chez tous les grands Cloud Providers. </p>
</div>
						<div class="entry-content"><div style="position:absolute;top:0;left:-9999px;">Want create site? Find <a href="http://dlwordpress.com/">Free WordPress Themes</a> and plugins.</div><div>L&rsquo;entreprise qui souscrit à ce service voit la gestion et les coûts liés à ses différentes composantes d&rsquo;infrastructures telles que les serveurs, les bases de données ou les montées en charge, disparaître ou très fortement diminuer. Débarrassé des contraintes liées à la sécurisation, au dimensionnement, au stockage et à la maintenance des serveurs, le développeur se concentre sur son métier&nbsp;: la création d&rsquo;applications.</div>
<div>
Si la promesse est alléchante, cette migration nécessite toutefois une adaptation technique et n&rsquo;est pas encore adaptée à tous les cas d&rsquo;usages.</div>
<h2><strong>Déléguer la performance de ses serveurs&nbsp;: une petite révolution</strong></h2>
<div>Demain, de nombreuses entreprises adopteront l&rsquo;approche serverless. Ces acteurs économiques reconnaissent s&rsquo;y intéresser notamment 21&nbsp;% franchissent actuellement ou ont déjà sauté le pas<sup>1</sup>. C&rsquo;est le cas de la NASA et du géant américain Coca-Cola, entre autres.</div>
<div>
Cette nouvelle architecture proposée par les grands <a href="https://www.silicon.fr/coronavirus-fournisseurs-cloud-336217.html">Cloud Providers</a> permet aux développeurs de créer et d&rsquo;exécuter leurs codes sans plus se préoccuper de la puissance des serveurs, de leur passage à l&rsquo;échelle, de leur entretien, ni même de leurs mises à jour.<br />
Fini également le casse-tête du déploiement de l&rsquo;application ou les problématiques de stockage, de load balancing et de réseau. Tout est désormais automatisé dans les serveurs du Cloud Provider&nbsp;!<br />
&nbsp;<br />
<a href="https://www.silicon.fr/salaires-developpeurs-10-pays-335683.html">Le développeur</a> peut ainsi mettre toute son énergie là où il délivre le plus de valeur ajoutée, à savoir la création des applications. La direction marketing, quant à elle, n&rsquo;a plus à se préoccuper du bon dimensionnement des serveurs en cas de pics de trafic.<br />
Enfin, la direction générale réalise de belles économies sur la gestion comme la maintenance de ses infrastructures, tout en s&rsquo;assurant d&rsquo;un très haut niveau de sécurité et de délivrance.<br />
De plus, le tarif du mode serverless étant calculé sur l&rsquo;usage réel et non plus dans le cadre d&rsquo;un forfait, le coût d&rsquo;exploitation des applications peut être divisé jusqu&rsquo;à 100.</div>
<h2><strong>Une nécessaire adaptation des process</strong></h2>
<div>&nbsp;</div>
<div>Plus qu&rsquo;une technologie, le serverless est avant tout un concept. À ce titre, il nécessite un changement d&rsquo;état d&rsquo;esprit autant que de façon de faire. Pour faire tourner une application sur cette architecture, le développeur doit séquencer son code au préalable, voire en redévelopper une partie. Cela nécessite des compétences spécifiques qui, si elles ne sont pas disponibles en interne, devront être acquises ou importées. Toutefois, les coûts liés à une éventuelle formation ou au recrutement d&rsquo;un expert seront vite compensés par les avantages obtenus grâce au serverless. &nbsp;<br />
&nbsp;<br />
De la même façon, pour gérer les bugs ou identifier des erreurs sur le code, le développeur devra intégrer d&rsquo;autres procédés, puisqu&rsquo;il n&rsquo;aura plus d&rsquo;accès direct aux serveurs. Enfin, il est indispensable que les applications qui tournent sur ce mode soient Cloud Native, c&rsquo;est-à-dire imaginée et conçue dans le Cloud.</div>
<p>Un peu comme on assemble des LEGO™, le développeur compose son modèle applicatif en se servant des briques de services du fournisseur. De fait, cette situation entraîne une forte dépendance au Cloud Provider. D&rsquo;autant qu&rsquo;en cas de migration vers un autre partenaire, une partie du code devra être retravaillée.</p><script type="text/javascript" id="VIDEO_INFEED-337196-0">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:VIDEO_INFEED-337196-0");var scr = document.getElementById("VIDEO_INFEED-337196-0");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-VIDEO_INFEED-337196-0");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-VIDEO_INFEED-0 desktop sticky-VIDEO_INFEED-337196-0");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",['fluid'], "div-gpt-ad-VIDEO_INFEED-337196-0").setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "['fluid']";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-VIDEO_INFEED-337196-0"] = {};hutt_defineSlot["div-gpt-ad-VIDEO_INFEED-337196-0"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-VIDEO_INFEED-337196-0"] = {};hutt_defineSlot_slot_object["div-gpt-ad-VIDEO_INFEED-337196-0"]["slot"] = slot;googletag.display("div-gpt-ad-VIDEO_INFEED-337196-0");});}</script>
<h2><strong>Pas toutes les applications et pas tout le temps&nbsp;!<br />
</strong></h2>
<div>Ce qui est important de bien avoir identifié avant de prendre la décision d&rsquo;adopter le serverless, ce sont les atouts et limites de cette architecture. L&rsquo;entreprise doit ensuite débuter modestement, sur un projet peu stratégique, afin que le développeur puisse se familiariser avec cette nouvelle approche. Attention également à bien prendre en compte le temps limite d&rsquo;exécution de la fonction, c&rsquo;est-à-dire à n&rsquo;utiliser le serverless que pour des applications qui entraînent des traitements courts comme le chargement d&rsquo;une page.<br />
En effet, ce mode n&rsquo;est absolument pas adapté à des tâches lourdes ou complexes telles que le traitement vidéo ni à toutes celles qui engagent un trafic constant, car elles entraîneraient une explosion des coûts dans le Cloud.</p>
<p>Aussi, la conception de l&rsquo;application en amont devra être parfaitement réfléchie pour être réellement pertinente en mode serverless.<br />
&nbsp;<br />
Certes aucune entreprise ne peut recourir à 100&nbsp;% à cette architecture aujourd&rsquo;hui. Toutefois, au vu de l&rsquo;engouement qu&rsquo;elle suscite, il y a fort à parier que d&rsquo;ici 10 ans, les composantes de l&rsquo;infrastructure ne seront plus un sujet pour les entreprises. &nbsp;<br />
&nbsp;<br />
&nbsp;<br />
<em><sup>1- Sondage publié en mai 2019 par le cabinet américain Datamation sur les entreprises qui ont recours au Serverless dans le cadre de leur déploiement cloud.</sup></em></div>
<div style="position:absolute;top:0;left:-9999px;">Did you find apk for android? You can find new <a href="https://dlandroid24.com/">Free Android Games</a> and apps.</div></p><div class="BeOpinionWidget"></div></div>
						<div class="visibility-end-of-article"></div>
					</section>
				</div>
				<footer class="entry-meta">
					<!--  new elements --><div itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.silicon.fr/wp-content/uploads/2020/02/serverless-datadog.jpg"><meta itemprop="width" content="866"><meta itemprop="height" content="653"></div><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.silicon.fr/wp-content/themes/kamino/assets/images/favicons_silicon/mstile-70x70.png"><meta itemprop="width" content=""><meta itemprop="height" content=""></div><meta itemprop="name" content="Le serverless : une mine d&#039;or pour les développeurs"></div><meta itemprop="datePublished" content="2020-03-30T18:00:14+00:00"/><meta itemprop="dateModified" content="2020-03-30T18:00:14+00:00"/><meta itemprop="headline" content="Le serverless : une mine d&#039;or pour les développeurs" /><meta itemprop="author" content="Philippe Leroy" /><meta itemscope itemprop="mainEntityOfPage" content="" itemType="https://schema.org/WebPage" itemid="https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs"/><!-- / nouveaux éléments -->					<script type="text/javascript" id="MOBILE_MPU-337196-4">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:MOBILE_MPU-337196-4");var scr = document.getElementById("MOBILE_MPU-337196-4");var device = "mobile";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-MOBILE_MPU-337196-4");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-MOBILE_MPU-4 mobile sticky-MOBILE_MPU-337196-4");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[[300, 250], [300, 600]], "div-gpt-ad-MOBILE_MPU-337196-4").setTargeting("pos", 4).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[[300, 250], [300, 600]]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-MOBILE_MPU-337196-4"] = {};hutt_defineSlot["div-gpt-ad-MOBILE_MPU-337196-4"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_MPU-337196-4"] = {};hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_MPU-337196-4"]["slot"] = slot;googletag.display("div-gpt-ad-MOBILE_MPU-337196-4");});}</script>					<aside class="clearfix" style="display: none">
						<div class="widget-title noBorder">Recommander cet article :</div>
						<div class="entry-social">
							            <span class="facebook-share btn-share">
                <a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs" target="_blank" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=400,width=600');return false;">
                    <span class="genericon genericon-facebook-alt"></span>
                    0                </a>
            </span>
                        <span class="twitter-share btn-share">
                <a rel="nofollow"
                   href="https://twitter.com/share?text=Le+serverless%C2%A0%3A+une+mine+d%27or+pour+les+d%C3%A9veloppeurs&url=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs"
                   target="_blank"
                   onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=400,width=600');return false;">
                    <span class="genericon genericon-twitter"></span>
                                    </a>
            </span>
                        <span class="linkedin-share btn-share">
                <a rel="nofollow" href="http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.silicon.fr%2Favis-expert%2Fle-serverless-une-mine-dor-pour-les-developpeurs&title=Le+serverless%C2%A0%3A+une+mine+d%27or+pour+les+d%C3%A9veloppeurs&source=https%3A%2F%2Fwww.silicon.fr" target="_blank" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=400,width=600');return false;">
                    <span class="genericon genericon-linkedin-alt"></span>
                    0                </a>
            </span>
            						</div>
						<div class="entry-tools"></div>
					</aside>
					    	<div class="tags">
    		<ul>
    			    			<li class="list_tag"><a href="https://www.silicon.fr/tag/serverless">serverless</a></li>
    			    		</ul>
    	</div>
    	            	<div class="author-header">
    		<div class="author-title">
    			<span>Auteur</span>
    		</div>
    		<div id="author-short_desc" class="vis">
    			<div class="author-avatar">
    				<a href="#">
    					<img src="https://www.silicon.fr/wp-content/uploads/2020/02/thumbnail_Artifakt_Aymeric_Aitamer_-__CEO.jpg" alt="Aymeric Aitamer" width="40">    				</a>
    			</div>
    			<div class="author-name">
    				<a href="#">
    					Aymeric Aitamer    				</a>
    			</div>
    			<div class="expandContent" id="expandContentTextShow" onclick="kamino_toggle_author_experts(this);">
    				<span class="vis">En savoir plus&nbsp;<i class="fa fa fa-chevron-down fa-2"></i></span>
    			</div>
    		</div>

    		<!-- author-summary -->
    		<div id="author-full_desc" class="invis">
    			<div id="showMe-337196" class="showMe">
    				<div class="author-avatar">
    					<a href="#">
    						<img src="https://www.silicon.fr/wp-content/uploads/2020/02/thumbnail_Artifakt_Aymeric_Aitamer_-__CEO.jpg" alt="Aymeric Aitamer" width="210">    					</a>
                        <div class="expert-social-links">
                                                    </div>
    				</div>
    				<div class="author-wrapper">
    					<div class="author-name">
    						<a href="#">
    							Aymeric Aitamer    						</a>
    					</div>
    					<div class="author-job">
    						CEO    					</div>
    					<div class="author-company">
    						Artifakt    					</div>
    				</div>
    				<div class="author-bio">
    					Aymeric Aitamer est CEO d'Artifakt    				</div>
    			</div>
    			<div class="expandContent" id="expandContentTextHide" onclick="kamino_toggle_author_experts(this);">
    				<span class="bar"></span>
    				<span class="button">
    					<span>En savoir plus&nbsp;<i class="fa fa fa-chevron-up fa-2"></i></span>
    				</span>
    			</div>
    		</div>
            <!-- /author-summary -->
            <script type="text/javascript">
                function kamino_toggle_author_experts(e) {
                    var expand_id = jQuery(e).attr("id");
                    jQuery("#author-full_desc").slideToggle('slow', function() {
                        if( expand_id == 'expandContentTextShow') {
                            console.log(expand_id);
                            jQuery('#author-short_desc').toggleClass('vis invis');
                            jQuery('#author-full_desc').toggleClass('invis vis');
                        }else {
                            jQuery('#author-full_desc').toggleClass('vis invis');
                            jQuery('#author-short_desc').toggleClass('invis vis');
                        }
                    });
                }
            </script>
        </div>
            				</footer><!-- .entry-meta -->
			</section>
			<aside class="wrap-article-info">
				<div class="wrap">
					<div class="before-mpu2-337196">
												<script type="text/javascript" id="DESKTOP_MPU-337196-1">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_MPU-337196-1");var scr = document.getElementById("DESKTOP_MPU-337196-1");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_MPU-337196-1");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_MPU-1 desktop sticky-DESKTOP_MPU-337196-1");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[[300, 250], [300, 600], [300, 90], [300, 1050]], "div-gpt-ad-DESKTOP_MPU-337196-1").setTargeting("pos", 1).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[[300, 250], [300, 600], [300, 90], [300, 1050]]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_MPU-337196-1"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_MPU-337196-1"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_MPU-337196-1"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_MPU-337196-1"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_MPU-337196-1");});}</script>
						
																	</div>
									</div>
			</aside>
		</article><!-- #post -->
	      <header class="bloc-whitepaper-header">
        <h1 class="bloc-whitepaper-title">
            Livres blancs A la Une        </h1>
      </header>
      <div class="whitepapers">
                      <article>
              <div class="image-whitepaper">
                <a href="https://livreblanc.silicon.fr/resource/ibm-cloud-object-storage-concretise-le-stockage-en-cloud-hybride">
                  <img width="135" height="182" alt="" src="https://livreblanc.silicon.fr/wp-content/uploads/2017/10/Capture3.png">
                </a>
              </div>
              <div class="title-whitepaper">
                <div class="title-whitepaper-container">
                  <h2>
                    <a href="https://livreblanc.silicon.fr/resource/ibm-cloud-object-storage-concretise-le-stockage-en-cloud-hybride">IBM Cloud Object Storage concrétise le stockage en cloud hybride</a>
                  </h2>
                  <h4 class="advertiser">IBM</h4>
                </div>
                <!-- .entry-header -->
                <div class="download-whitepaper">
                  <a href="https://livreblanc.silicon.fr/resource/ibm-cloud-object-storage-concretise-le-stockage-en-cloud-hybride">Télécharger</a>
                </div>
              </div>
            </article>
                          <article>
              <div class="image-whitepaper">
                <a href="https://livreblanc.silicon.fr/resource/les-capacites-critiques-du-stockage-objet">
                  <img width="135" height="182" alt="" src="https://livreblanc.silicon.fr/wp-content/uploads/2017/10/Capture5.png">
                </a>
              </div>
              <div class="title-whitepaper">
                <div class="title-whitepaper-container">
                  <h2>
                    <a href="https://livreblanc.silicon.fr/resource/les-capacites-critiques-du-stockage-objet">Les capacités critiques du stockage objet</a>
                  </h2>
                  <h4 class="advertiser">IBM</h4>
                </div>
                <!-- .entry-header -->
                <div class="download-whitepaper">
                  <a href="https://livreblanc.silicon.fr/resource/les-capacites-critiques-du-stockage-objet">Télécharger</a>
                </div>
              </div>
            </article>
                          <article>
              <div class="image-whitepaper">
                <a href="https://livreblanc.silicon.fr/resource/evaluation-des-fournisseurs-de-stockage-objet-en-2016">
                  <img width="135" height="182" alt="" src="https://livreblanc.silicon.fr/wp-content/uploads/2017/10/Capture4.png">
                </a>
              </div>
              <div class="title-whitepaper">
                <div class="title-whitepaper-container">
                  <h2>
                    <a href="https://livreblanc.silicon.fr/resource/evaluation-des-fournisseurs-de-stockage-objet-en-2016">Évaluation des fournisseurs de stockage objet en 2016</a>
                  </h2>
                  <h4 class="advertiser">IBM</h4>
                </div>
                <!-- .entry-header -->
                <div class="download-whitepaper">
                  <a href="https://livreblanc.silicon.fr/resource/evaluation-des-fournisseurs-de-stockage-objet-en-2016">Télécharger</a>
                </div>
              </div>
            </article>
                    </div>
    </div><!-- #content -->

<!-- Vertical Social share -->
<script type="text/javascript">
	(function ($) {
		var postID = 337196;
		var selector = $('.entry-social-v3.postID-' + postID);
		if (selector.length) {
			$(selector).stickySocialbar({
				wrapperSelector: '.articleWrapper'
			});
		}
		$(window).load(function () {
			var selector = $('.entry-social-v3.postID-' + postID);
			if (selector.length) {
				$(selector).stickySocialbar({
					wrapperSelector: '.articleWrapper'
				});
			}
	});
}(jQuery));
</script>
<!-- GA visibility-->
<script type="application/javascript">
	kaminoVisibility.seenEndOfArticle = false;

	jQuery(window).scroll(function () {
		if (!kaminoVisibility.seenEndOfArticle && (jQuery)('.visibility-end-of-article').kaminoIsOnScreen()) {
			// console.log('triggered:visibility-end-of-article!');
			ga('send', 'event', 'visibility', 'end-of-article', 'on:' + 'https://www.silicon.fr/avis-expert/le-serverless-une-mine-dor-pour-les-developpeurs');
			kaminoVisibility.seenEndOfArticle = true;
		}
	});

</script>
<div id="infinite-scroll-marker-end" style="display: none;"></div>
<script type="text/javascript" id="MOBILE_BANNER-337196-2">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:MOBILE_BANNER-337196-2");var scr = document.getElementById("MOBILE_BANNER-337196-2");var device = "mobile";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-MOBILE_BANNER-337196-2");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-MOBILE_BANNER-2 mobile sticky-MOBILE_BANNER-337196-2");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[[320, 50], [300, 50]], "div-gpt-ad-MOBILE_BANNER-337196-2").setTargeting("pos", 2).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[[320, 50], [300, 50]]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-MOBILE_BANNER-337196-2"] = {};hutt_defineSlot["div-gpt-ad-MOBILE_BANNER-337196-2"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_BANNER-337196-2"] = {};hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_BANNER-337196-2"]["slot"] = slot;googletag.display("div-gpt-ad-MOBILE_BANNER-337196-2");});}</script><script type="text/javascript" id="DESKTOP_MEGA-337196-2">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_MEGA-337196-2");var scr = document.getElementById("DESKTOP_MEGA-337196-2");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_MEGA-337196-2");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_MEGA-2 desktop sticky-DESKTOP_MEGA-337196-2");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[[728, 90], [728, 200], [976, 220], [970, 90], [970, 150], [970, 250], [1014, 90], [1014, 200], [1014, 300], [1080, 90], [1080, 200], [1080, 250], [1080, 300], [1080, 440], [978, 250], [1000, 200], [1000, 300], [1000, 90], [728, 270]], "div-gpt-ad-DESKTOP_MEGA-337196-2").setTargeting("pos", 2).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[[728, 90], [728, 200], [976, 220], [970, 90], [970, 150], [970, 250], [1014, 90], [1014, 200], [1014, 300], [1080, 90], [1080, 200], [1080, 250], [1080, 300], [1080, 440], [978, 250], [1000, 200], [1000, 300], [1000, 90], [728, 270]]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_MEGA-337196-2"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_MEGA-337196-2"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_MEGA-337196-2"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_MEGA-337196-2"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_MEGA-337196-2");});}</script>    </div><!-- #main -->
    

            </div><!-- #page -->

            
                        <!-- Segment Pixel - FR - Silicon.fr - DO NOT MODIFY -->
                        <img src="https://secure.adnxs.com/seg?add=6084217&t=2" width="1" height="1"/>
                        <!-- End of Segment Pixel -->

                                    
            <footer id="footer" class="site-footer" role="contentinfo">
                
    <script type="text/javascript" defer="defer">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</script>

		<div id="editorial-popin" class="fadeInUp" data-number-views = 1 data-timeout = 20>
			<span id="close-popin">&times;</span>
			<div class="wrapper">
				<div class="content">
					<span class="titel-editorial">Ne manquez pas cet article</span>
					<div class="text-editorial"><span>Coronavirus : ces sociétés IT qui ouvrent gratuitement leur service<span></div>
					<a id="readEditorial" href="https://www.silicon.fr/coronavirus-ces-societes-it-qui-ouvrent-gratuitement-leur-service-336318.html?utm_source=slider-edito&utm_medium=site" class="btn-editorial">Lire</a>
				</div>
			</div>
		</div>
	            
                <div class="wrapper">
                    <aside id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-title">Services</div><div class="menu-footer-1-container"><ul id="menu-footer-1" class="menu"><li id="menu-item-97262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97262"><a rel="nofollow" href="https://emploi.silicon.fr/">Emplois, jobs Informatique</a></li>
<li id="menu-item-97226" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97226"><a rel="nofollow" href="https://inscription.silicon.fr/profile/login.php?continue=http%3A%2F%2Fwww.silicon.fr%2F&#038;continue_label=Silicon">Votre compte</a></li>
<li id="menu-item-97264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97264"><a rel="nofollow" href="/plan-du-site">Plan du site</a></li>
<li id="menu-item-97229" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97229"><a rel="nofollow" href="/adresse-ip">Quelle est mon adresse IP ?</a></li>
</ul></div></aside><aside id="nav_menu-4" class="widget widget_nav_menu"><div class="widget-title">Sites</div><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-97267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97267"><a rel="nofollow" href="https://livreblanc.silicon.fr/">Livres Blancs Informatiques</a></li>
<li id="menu-item-97231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97231"><a rel="nofollow" href="https://telecharger.itespresso.fr/">Télécharger</a></li>
<li id="menu-item-97269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97269"><a rel="nofollow" href="https://www.itespresso.fr">ITespresso</a></li>
<li id="menu-item-97233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97233"><a rel="nofollow" href="https://www.channelbiz.fr">Channelbiz</a></li>
<li id="menu-item-335988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-335988"><a target="_blank" href="http://boutique.editialis.fr/marketing-commercial/silicon">Silicon Magazine</a></li>
</ul></div></aside><aside id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-title">Mentions légales</div><div class="menu-footer-3-container"><ul id="menu-footer-3" class="menu"><li id="menu-item-97295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97295"><a href="https://www.silicon.fr/conditions-generales-dutilisation">Conditions Générales d&rsquo;Utilisation</a></li>
<li id="menu-item-97297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97297"><a href="https://www.silicon.fr/politique-confidentialite-cookies">Politique de Confidentialité &#8211; Gestion des cookies</a></li>
</ul></div></aside><aside id="nav_menu-6" class="widget widget_nav_menu"><div class="widget-title">Rester en contact</div><div class="menu-footer-4-container"><ul id="menu-footer-4" class="menu"><li id="menu-item-97291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97291"><a href="/services/contactez-la-redaction">Contactez la rédaction</a></li>
<li id="menu-item-335715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-335715"><a href="https://www.silicon.fr/services/contactez-la-technique">Contactez la technique</a></li>
<li id="menu-item-97292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97292"><a href="/services/contactez-la-regie">Contactez la régie</a></li>
<li id="menu-item-98334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98334"><a href="https://www.silicon.fr/services/contactez-service-etude">Contactez le service étude</a></li>
<li id="menu-item-97290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97290"><a href="https://www.silicon.fr/services/proposition-de-partenariat">Proposition de partenariat</a></li>
<li id="menu-item-97294" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97294"><a href="/services/contact#annoncer">Annoncer sur Silicon.fr</a></li>
</ul></div></aside><aside class="widget widget_text int"><div class="textwidget"><span class="titel-flags">NETMEDIAEUROPE : </span><ul><li class="br"><a href="//www.bitmag.com.br/">Brésil</a></li><li class="de"><a href="//www.silicon.de/">Allemagne</a></li><li class="fr"><a href="//www.silicon.fr/">France</a></li><li class="it"><a href="//www.silicon.it/">Italie</a></li></ul><ul><li class="pt"><a href="//www.bit.pt/">Portugal</a></li><li class="es"><a href="//www.silicon.es/">Espagne</a></li><li class="uk"><a href="//www.silicon.co.uk/">Royaume-Uni</a></li><li class="wo"><a href="//www.netmediaeurope.com/">Monde</a></li></ul><span class="top-page"><a id="back-top" href="">Top of the page</a></span></div></aside>                </div>
                <div class="site-info">
                NetMediaEurope &copy; Copyright 2020 Tous droits réservés. <a href="https://www.netmediaeurope.com" title="NetMediaEurope">A propos de NetMediaEurope</a>                </div>
                <!-- .site-info -->
            </footer><!-- #colophon -->
            <!-- ngg_resource_manager_marker --><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.silicon.fr\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.silicon.fr/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7" defer="defer" ></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/www.silicon.fr\/wp\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"Les erreurs suivantes sont survenues:","text_name_invalid":"- Votre Nom est vide ou non-valide","text_email_invalid":"- Votre Email  est vide ou non-valide","text_remarks_invalid":"- Votre commentaire n'est pas valide","text_friend_names_empty":"- Nom(s) d'Amis(s) vide(s)","text_friend_name_invalid":"- Nom d'Ami vide ou non-valide: ","text_max_friend_names_allowed":"- Maximum 5 Noms d'Amis autoris\u00e9s","text_friend_emails_empty":"- Email(s) d'Ami(s) vide(s)","text_friend_email_invalid":"- Email d'Ami non valide:","text_max_friend_emails_allowed":"- Maximum 5 Emails d'Amis autoris\u00e9s","text_friends_tally":"- Le nombre de Nom(s) d'Ami(s) ne correspond pas au nombre d'Email(s) d'Ami(s)","text_image_verify_empty":"- Code anti-spam vide"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/plugins/wp-email/email-js.js?ver=2.67.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.silicon.fr\/wp\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.4'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LdbRJsUAAAAACP4b8FEV_0kQGnFckwfYCLRaixm&#038;ver=3.0'></script>
<script type='text/javascript' src='https://www.silicon.fr/wp/wp-includes/js/comment-reply.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/themes/kamino/assets/js/waypoints/jquery.waypoints.min.js?ver=1_1.54.9-zABW_0.0.2-nypd'></script>
<script type='text/javascript' src='https://www.silicon.fr/wp-content/themes/kamino/assets/js/waypoints/shortcuts/infinite.min.js?ver=1_1.54.9-zABW_0.0.2-nypd'></script>
<script type='text/javascript' src='https://www.silicon.fr/wp/wp-includes/js/wp-embed.min.js?ver=4.9.13'></script>
<script type="text/javascript" id="DESKTOP_PRE_HOME-337196-1">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_PRE_HOME-337196-1");var scr = document.getElementById("DESKTOP_PRE_HOME-337196-1");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_PRE_HOME-337196-1");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_PRE_HOME-1 desktop sticky-DESKTOP_PRE_HOME-337196-1");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[2, 2], "div-gpt-ad-DESKTOP_PRE_HOME-337196-1").setTargeting("pos", 1).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[2, 2]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_PRE_HOME-337196-1"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_PRE_HOME-337196-1"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_PRE_HOME-337196-1"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_PRE_HOME-337196-1"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_PRE_HOME-337196-1");});}</script><script type="text/javascript" id="DESKTOP_FLASH_TRANS-337196-0">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_FLASH_TRANS-337196-0");var scr = document.getElementById("DESKTOP_FLASH_TRANS-337196-0");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_FLASH_TRANS-337196-0");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_FLASH_TRANS-0 desktop sticky-DESKTOP_FLASH_TRANS-337196-0");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[5, 5], "div-gpt-ad-DESKTOP_FLASH_TRANS-337196-0").setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[5, 5]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_FLASH_TRANS-337196-0"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_FLASH_TRANS-337196-0"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_FLASH_TRANS-337196-0"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_FLASH_TRANS-337196-0"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_FLASH_TRANS-337196-0");});}</script><script type="text/javascript" id="DESKTOP_FOOTER-337196-0">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_FOOTER-337196-0");var scr = document.getElementById("DESKTOP_FOOTER-337196-0");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_FOOTER-337196-0");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_FOOTER-0 desktop sticky-DESKTOP_FOOTER-337196-0");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[6, 6], "div-gpt-ad-DESKTOP_FOOTER-337196-0").setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[6, 6]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_FOOTER-337196-0"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_FOOTER-337196-0"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_FOOTER-337196-0"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_FOOTER-337196-0"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_FOOTER-337196-0");});}</script><script type="text/javascript" id="DESKTOP_SITE_UNDER-337196-0">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:DESKTOP_SITE_UNDER-337196-0");var scr = document.getElementById("DESKTOP_SITE_UNDER-337196-0");var device = "desktop";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-DESKTOP_SITE_UNDER-337196-0");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-DESKTOP_SITE_UNDER-0 desktop sticky-DESKTOP_SITE_UNDER-337196-0");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[3, 3], "div-gpt-ad-DESKTOP_SITE_UNDER-337196-0").setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[3, 3]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-DESKTOP_SITE_UNDER-337196-0"] = {};hutt_defineSlot["div-gpt-ad-DESKTOP_SITE_UNDER-337196-0"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_SITE_UNDER-337196-0"] = {};hutt_defineSlot_slot_object["div-gpt-ad-DESKTOP_SITE_UNDER-337196-0"]["slot"] = slot;googletag.display("div-gpt-ad-DESKTOP_SITE_UNDER-337196-0");});}</script><script type="text/javascript" id="MOBILE_PRE_HOME-337196-2">var screensize = document.documentElement.clientWidth;if (screensize  < 1800) {var minscreenwidth = "1280";} else {var minscreenwidth = "1920";}var u_company = "n/a";var u_job_description = "n/a";var u_company_size = "n/a";var u_industry = "n/a";if (kaminoCookie.getItem("ct_echo") != undefined) {var ct_echo = JSON.parse(kaminoCookie.getItem("ct_echo"));ct_echo.details = ct_echo.details || {};u_company = ct_echo.company || "n/a";u_job_description = ct_echo.details.jd || "n/a";u_company_size = ct_echo.details.ne || "n/a";u_industry = ct_echo.details.is || "n/a";}console.log("id:MOBILE_PRE_HOME-337196-2");var scr = document.getElementById("MOBILE_PRE_HOME-337196-2");var device = "mobile";if(dfp_device_view == device){var slot_div = document.createElement("div");slot_div.setAttribute("id", "div-gpt-ad-MOBILE_PRE_HOME-337196-2");slot_div.setAttribute("class", "dfp_ad div-gpt-ad-MOBILE_PRE_HOME-2 mobile sticky-MOBILE_PRE_HOME-337196-2");slot_div.setAttribute("height", "0");var word = "";if(word != ""){var slot_word_div = document.createElement("div");slot_word_div.setAttribute("class", "dfp_word");slot_word_div.innerHTML = word;slot_div.appendChild(slot_word_div);}scr.parentNode.insertBefore(slot_div, scr.nextSibling);googletag.cmd.push(function() {var infinite_scroll = false;if("" != ""){infinite_scroll = true;if(hutt_original_page_id != ""){hutt_original_page_id = "";hutt_defineSlot_slot_object_infinite_scroll = [];}}var slot = googletag.defineSlot("/14668010/silicon/special",[2, 2], "div-gpt-ad-MOBILE_PRE_HOME-337196-2").setTargeting("pos", 2).setTargeting("type", "expertadvice").setTargeting("artid", "337196").setTargeting("key", "le-serverless-une-mine-dor-pour-les-developpeurs").setTargeting("cat", ["projects","devops","cloud"]).setTargeting("tag", "serverless").setTargeting("displayed_experts", "aymeric-aitamer").setTargeting("min_width", minscreenwidth).setTargeting("job_description", u_job_description).setTargeting("company_size", u_company_size).setTargeting("industry", u_industry).setTargeting("company", u_company).addService(googletag.pubads());if(infinite_scroll == true){hutt_defineSlot_slot_object_infinite_scroll.push( slot );}var size = "[2, 2]";size = size.replace(/\s+/g, "");hutt_defineSlot["div-gpt-ad-MOBILE_PRE_HOME-337196-2"] = {};hutt_defineSlot["div-gpt-ad-MOBILE_PRE_HOME-337196-2"]["size"] = size;hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_PRE_HOME-337196-2"] = {};hutt_defineSlot_slot_object["div-gpt-ad-MOBILE_PRE_HOME-337196-2"]["slot"] = slot;googletag.display("div-gpt-ad-MOBILE_PRE_HOME-337196-2");});}</script>
                <!-- OneSixty2 code begin -->
                <img src='https://secure.adnxs.com/seg?add=11175678&t=2' width='1' height='1'/>
                <!-- OneSixty2 code end -->
                <script type="text/javascript" id="quantx-embed-tag" src="//cdn.elasticad.net/native/serve/js/quantx/nativeEmbed.gz.js"></script>         <!-- Webpage Tag 9931 / Silicon.fr -->
        <script type="text/javascript">    
            (function(){    
                var myrtbHost = (("https:" == document.location.protocol) ? "https://lib." : "http://lib.");
                var myrtbScript = document.createElement("script");
                myrtbScript.type = "text/javascript";
                myrtbScript.async = true;        
                myrtbScript.src=myrtbHost+"selfcampaign.com/tag/9931_1063f48e983d95f1fece27debed6e4b7?async=1";
                (document.getElementsByTagName("head")[0]||document.getElementsByTagName("body")[0]).appendChild(myrtbScript);    
            })();
        </script>
                <script type="text/javascript">
            (function ( $ ) {
                var screenWidth = $( window ).width(),
                    wpadminbar;
                if ( screenWidth < 751 )
                    return;

                if ( $( 'header[role=banner]' ).length > 0 ) {
                    var headerPos = $( 'header[role=banner]' ).position().top;
                } else {
                    return;
                }

                if ( $( 'body' ).hasClass( 'admin-bar' ) ) {
                    wpadminbar = 32;
                } else {
                    wpadminbar = 0;
                }

                var headerLightPos = $( 'header.single-nav' ).position().top;

                var display = false;

                //function to show and hide headers
                function showLightHeader() {
                    display = true;
                    $( 'header.single-nav' ).animate( {
                        top: headerPos
                    }, 500 );
                    $( 'header[role=banner]' ).animate( {
                        top: headerLightPos
                    }, 500 );
                }

                function hideLightHeader() {
                    display = false;
                    $( 'header.single-nav' ).animate( {
                        top: headerLightPos
                    }, 'fast' );
                    $( 'header[role=banner]' ).animate( {
                        top: headerPos
                    }, 'fast' );
                }

                //Modify header position when scroll
                $( document ).scroll( function ( event ) {
                    if ( $( this ).scrollTop() >= 400 ) {
                        if ( display != true ) {
                            showLightHeader();
                            //console.log('show');
                        }
                    }
                    else {
                        if ( display ) {
                            hideLightHeader();
                            //console.log('hide');
                        }
                    }
                } );

                //scroll to top
                $( '.single-scroll-top .glyphicon' ).click( function () {
                    $( 'body,html' ).animate( {
                        scrollTop: 0
                    }, 800 );
                    return false;
                } );


            }( jQuery ));
        </script>
        <script type="text/javascript">
        (function ($) {
            $(window).load(function() {

                var site_name = "silicon.fr",
                    riverline_site_name = site_name.replace('.fr', '.gif'),
                    cookie_webtracking_id = 'spcd_uuid',
                    display_pixel = true;

                // get user webtracking id
                var user_webtracking_id = kaminoCookie.getItem(cookie_webtracking_id);
                if(!user_webtracking_id){
                    display_pixel = false;
                }

                if (display_pixel == true) {
                    var urlImg = "//api.optinproject.com/rt/visit/"+riverline_site_name+"?metas[uuid]="+user_webtracking_id;

                    // Insert image at the end of body
                    $("body").append('<img border="0" alt="0" width="1" height="1" alt="" src="' + urlImg + '"/>');

                }
            });

        }(jQuery));
    </script>
<script type="text/javascript">
( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LdbRJsUAAAAACP4b8FEV_0kQGnFckwfYCLRaixm',
	{"homepage":"homepage","contactform":"contactform"}
);
</script>
            <!-- FOOTER END -->
                        <script type="text/javascript" >
            jQuery(document).ready(function () {
                // ANW-3 : limiting characters title post editorial popin
                jQuery("#editorial-popin .text-editorial").text(function(i, titel) {
                        return (titel.length > 68) ? titel.substring(0, 68) + '..' : titel;
                });

                // scroll body to 0px on click
                jQuery("#back-top").click(function () {
                    jQuery('body,html').animate({
                            scrollTop: 0
                        }, 800);
                        return false;
                    });
            });
            </script>
        </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/


Served from: silicon.ig-1.net @ 2020-03-30 22:00:39 by W3 Total Cache
-->